Go Back   Zukikrawlers > Technical > Suzuki Engine
Photo Gallery Home Forum FlashChat Email

Suzuki Engine Discuss all your engine questions, troubles, and tech in this area.

Reply
 
Thread Tools Display Modes
Old 07-11-2018, 06:26 PM   #1
3006mv
 
Join Date: Jun 2018
Location: Moreno Valley
Posts: 11
Rep Power: 0
3006mv is an unknown quantity at this point
1.3l carburetor parts

so i kept failing smog here in CA with high CO. my mech said my choke is not opening (causing rich condition?) so he suggested I get 3 carb parts. I got them on ebay but have not installed them yet. Do you think this will help me pass smog? if my parts are no good what is my next step? installing a manual choke cable? I have a new CC and muffler, spark plugs (one up hotter), new fuel filter, new oil and oil filter and new pcv valve. the parts I got which i hope work are: choke pull off , idle up actuator, and wax thermo element and housing. I wish someone like in India has some new wax elements b/c I doubt the one i got on ebay is any better condition than mine. i.e. does not work.
My '86 zook has always passed smog in past, i think something went bad since last time b/c i was blowing smoke and believe i ruined my cat, but dumb me didn't know any better and just kept driving it. being in hot CA i dont have starting issues or driving in "cold" thus never thought about the choke staying closed, now that I think about it now I know why I was getting bad gas mileage. I never really did smell any fuel under the hood.
3006mv is offline   Reply With Quote
Old 08-11-2018, 06:32 PM   #2
bigfootford
 
Join Date: May 2011
Location: Fair Oaks, Calif
Posts: 9
Rep Power: 0
bigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond repute
Wow, no one has jumped on your thread and offered some help. I saw it a couple of weeks ago and cringed about the choke, thermo wax element etc... I have been through this subject in depth. The first thing to do is download the Factory Service manual and go to the carb section and begin...

As a help here are a couple of threads of a buddy of mine going through smog failures etc. A great educational read... We both have Z's and have struggled to pass Cal Smog.

Here is a couple of threads he started.. I am referenced sometimes..hahahaaa.



http://https://bbs.zuwharrie.com/content?topic=133663.0

http://https://bbs.zuwharrie.com/con...35.0#gsc.tab=0

Lets just start with these and see how things go.

If you have read a thread that talks about bending the tab that sits on the end of the thermal Wax unit DO NOT bend that tab as of yet.

The choke is easy to see if it is open or closed... It also is easy to watch that thermal wax unit expand as the engine warms up. If the tab is already bent it probably has destroyed the wax unit.

Jim
bigfootford is offline   Reply With Quote
Old 08-16-2018, 10:36 PM   #3
3006mv
 
Join Date: Jun 2018
Location: Moreno Valley
Posts: 11
Rep Power: 0
3006mv is an unknown quantity at this point
thanks for your reply. I ended up installing those parts. then still failed smog b/c running too lean. just my luck. so i am tracking down an EGR valve now. will see if that solves my issue. I got all my vacuum lines corrected/replaced so that is all good.
3006mv is offline   Reply With Quote
Old 08-17-2018, 10:42 AM   #4
bigfootford
 
Join Date: May 2011
Location: Fair Oaks, Calif
Posts: 9
Rep Power: 0
bigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond repute
What kind of numbers are you getting?

In your first post you said "Rich"

In the last post you said "Too lean".

So in which test was the engine lean?

Could just be as simple as adjusting the Idle mixture screw. It sucks that the tech would say to you that you need to richen the idle... They are not allowed to tell you anything.

You might need to go to a Star station that also does repair... So they can tell you what is going on.

EGR can be leaking a bit. I would take it off and clean it up you can test it for leaking yourself.
Don't spend any $ on an EGR valve yet...

This video shows how to test... No need to obtain a vacuum pump.. Just get some tubing and suck on it then put your tongue on the tube and see if the it holds vacuum.
I use brake cleaner for the solution... Oil is slow to show a leak... Cleaner will ooze through quickly.

https://www.youtube.com/watch?v=DqUCbbKdWf4




Jim
__________________
87 Z Tin Top...3 friends that have Z's.

Last edited by bigfootford; 08-17-2018 at 10:54 AM.
bigfootford is offline   Reply With Quote
Old 08-28-2018, 01:31 PM   #5
3006mv
 
Join Date: Jun 2018
Location: Moreno Valley
Posts: 11
Rep Power: 0
3006mv is an unknown quantity at this point
It was rich before I got my carb parts. It was lean after. I passed just today with a new EGR installed. The old one was bad, it didn’t pass the check from the vid. But a weird thing happened during the test. To get to the 25mph test the tech said the numbers were high (nox) in 3rd gear but when he put it in 4th they dropped back. I passed at any rate but why did the EGR kick off at third gear?! box of replaced parts

Last edited by 3006mv; 08-28-2018 at 06:07 PM.
3006mv is offline   Reply With Quote
Old 08-28-2018, 05:06 PM   #6
bigfootford
 
Join Date: May 2011
Location: Fair Oaks, Calif
Posts: 9
Rep Power: 0
bigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond repute
Quote:
Originally Posted by 3006mv View Post
It was rich before I got my carb parts. It was lean after. I passed just today with a new EGR installed. The old one was bad, it didnít pass the check from the vid. But a weird thing happened during the test. To get to the 25mph test the tech said the numbers were high (nox) in 3rd gear but when he put it in 4th they dropped back. I passed at any rate but why did the EGR kick off at third gear?!
Well it is great that you passed... As for what happened in 3rd and passed in 4th it could be lots of things.... I would check every vacuum hose and make sure they are all good...
It could be that the new O2 sensor is not up to par either....

At this point I would not worry, you have 2 years... If you gas mileage is over 20 I would not be at all concerned.

Jim
__________________
87 Z Tin Top...3 friends that have Z's.
bigfootford is offline   Reply With Quote
Old 08-28-2018, 05:58 PM   #7
3006mv
 
Join Date: Jun 2018
Location: Moreno Valley
Posts: 11
Rep Power: 0
3006mv is an unknown quantity at this point
ha ha thanks, that is actually exactly what I was thinking. the O2 sensor is new, as is the muffler and cat converter. I will do a checkover however as I am continually wrenching on this thing

box of replaced parts

Last edited by 3006mv; 08-28-2018 at 06:13 PM.
3006mv is offline   Reply With Quote
Old 08-28-2018, 06:05 PM   #8
bigfootford
 
Join Date: May 2011
Location: Fair Oaks, Calif
Posts: 9
Rep Power: 0
bigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond reputebigfootford has a reputation beyond repute
Ah, that one looks nice!

Know what you mean about wrenching on the thing!

Past 2 years I have rebuilt/long blocked the engine, rebuilt trans and getting ready to do the transfer case to 4.16.... Mine is all stock.

I have 3 bud's that have Z's.

__________________
87 Z Tin Top...3 friends that have Z's.
bigfootford is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1.3l w/weber and parts CM COWS Parts & Accessories For Sale 19 07-06-2014 06:37 PM
1.3L Double Row Pulley (For adding PS) ROKZUKI Parts & Accessories For Sale 1 08-16-2012 09:40 PM
Trackick trans on 1.3L little Loopie Suzuki Engine 3 01-11-2011 08:11 PM
Wtb: 1.3l samuride1 Wanted Ads 0 06-26-2010 09:47 AM
1.6L EFI Swap onto 1.3L Motor JPR Ram Suzuki Engine 5 01-03-2009 02:18 PM


All times are GMT -5. The time now is 02:04 PM.

design by Themes by Design

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2005-2017 Zukikrawlers.com